GoToMeeting website delay
Resolved
This issue has been resolved and www.gotomeeting.com is 100% operational at this time.
Posted Apr 20, 2016 - 15:04 UTC
Investigating
We have received reports that logging into http://www.gotomeeting.com may be taking longer than usual or the page may not load at all. As a temporary workaround, please use http://global.gotomeeting.com. Launching GoToMeeting through the end point software is not impacted.

We apologize for the inconvenience this may cause you and your customers. We are working to get this restored as quickly as possible.
Posted Apr 20, 2016 - 13:53 UTC
This incident affected: GoToMeeting.