GoToWebinar Email Latency
Postmortem

On 8/7/2014 from 2:50PM UTC - 5:25 PM UTC a limited number of customers experienced a delay in receiving GoToWebinar email invitations. This issue was the result of a temporary increase in email traffic. We sincerely apologize for the disruption in service to you and your customers.

Posted Aug 08, 2014 - 22:35 UTC

Resolved
The GoToWebinar invitation email latency issue is now resolved. We apologize for any trouble this may have caused you. The root cause analysis will follow.
Posted Aug 07, 2014 - 20:43 UTC
Investigating
We are currently investigating an issue that is affecting some GoToWebinar customers. GoToWebinar invitation emails being sent to some customers is being delayed. We are working to identify the cause and resolve this delay. We apologize for any frustration or inconvenience this issue is causing.
Posted Aug 06, 2014 - 18:44 UTC
This incident affected: GoToWebinar.