OpenVoice Calls Not Starting
Resolved
At this time service has been fully restored. We apologize for any frustration experienced and thank you for your patience.
Posted Nov 14, 2014 - 20:19 UTC
Investigating
We are currently investigating issues with our OpenVoice bridges that are affecting several customers. Those experiencing difficulties are able to connect to our phone numbers, but are unable to start their conferences after entering their Conference ID. Current reports state that they hear a series of beeps and then the calls are dropped.

This is top priority and we are working towards a resolution as quickly as possible.
Posted Nov 14, 2014 - 16:38 UTC
This incident affected: OpenVoice.