Impacted Instant Join Flow For GoToMeeting, GoToWebinar and GoToTraining, Delays Loading the My Meetings Page
Incident Report for GoToMeeting® System Status
Resolved
This incident was a result of a service disruption with Amazon Web Services (AWS) which in turn affected some parts of our applications. Please visit the Amazon Health page under "Status History" for additional information about these incidents. We have confirmed that the issue has been completely resolved and all systems are 100% operational at this time. We apologize for an inconvenience this has caused you and your customers.
Posted 8 months ago. Feb 28, 2017 - 22:54 UTC
Monitoring
At this time we have confirmed that all impacted services have been restored. We are continuing to monitor the situation closely to ensure the complete stability of the platform.
Posted 8 months ago. Feb 28, 2017 - 22:15 UTC
Update
We are seeing improvement in impacted services, though some remain intermittently affected. We expect the service to continue to improve moving forward and are monitoring the situation closely.
Posted 8 months ago. Feb 28, 2017 - 21:06 UTC
Update
We have determined the issue to be within our service provider and are continuing to work to resolve this issue. Customers may continue to experience problems joining meetings, webinars, or training sessions. Our website may be slow to respond and other components listed in the previous update may also continue to be impacted. Thank you for your patience while we work through this issue.
Posted 8 months ago. Feb 28, 2017 - 19:32 UTC
Update
We have determined that the issues we are currently experiencing are also impacting the Instant Join flows for GoToTraining and GoToWebinar. Joining and hosting sessions using the application flow is unaffected.

Currently Impacted Services:
Instant Join flow for GoToMeeting, GoToWebinar, and GoToTraining
GoToMeeting Outlook Plug-in
Google Calendar Plug-in
GoToWebinar Report Generation
GoToWebinar and GoToTraining Recording Playback
Posted 8 months ago. Feb 28, 2017 - 19:02 UTC
Identified
We have identified the source of the disruption and are working to mitigate the issues.
Posted 8 months ago. Feb 28, 2017 - 18:43 UTC
Update
We have determined that the Instant Join flow for joining sessions may also be affected by this issue, as well as retrieving the invitation text for new meetings through the GoToMeeting application. Joining and starting sessions via the GoToMeeting application is unaffected. We are continuing to investigate and work towards a resolution.
Posted 8 months ago. Feb 28, 2017 - 18:27 UTC
Investigating
We are receiving reports of delays loading the My Meetings page after logging into the website at gotomeeting.com. We are actively investigating this issue. Active sessions do not appear to be affected.
Posted 8 months ago. Feb 28, 2017 - 18:09 UTC
This incident affected: GoToMeeting, GoToWebinar, and GoToTraining.