GoToMeeting Service Unavailable
Resolved
Service has been fully restored. We sincerely apologize for the inconvenience to you and your customers.
Posted Sep 10, 2015 - 15:33 UTC
Investigating
We have had a number of reports of issues launching and/or joining GoToMeeting sessions this morning. Our operations and engineering teams are aware and working towards a resolution, and we will keep this page updated as new information is available.

We sincerely apologize for any inconvenience this has caused.
Posted Sep 10, 2015 - 13:22 UTC