OpenVoice callers dialing into Mexico Toll numbers get dead air/call dropped
Resolved
Our carrier has reported that this incident is resolved. We have confirmed that we are 100% operational.

We sincerely apologize for those affected by this incident.
Posted Nov 09, 2015 - 23:04 UTC
Investigating
OpenVoice participants using the following Mexico dial-in numbers may experience difficulty joining the conference:
+525547740251
+525547740252
+525547740253

At this time it is recommended they use Toll for another country to connect or Mexico Toll Free (where available). A high priority ticket has been filed with our provider and this issue is currently under investigation.
Posted Nov 09, 2015 - 19:20 UTC