Login and Delays Starting Sessions
Incident Report for GoToMeeting® System Status
Resolved
The issue is completely resolved. All systems are 100% operational.

We apologize for the inconvenience this may have caused to you and your customers.
Posted 26 days ago. Oct 25, 2017 - 07:58 UTC
Monitoring
We are continuing to monitor this issue. We identified a group of east coast network and internet outages as the likely cause. Please call our support team should you experience any further issues.
Posted 27 days ago. Oct 24, 2017 - 17:55 UTC
Update
Current work around: Quit and restart the effected program and should that not resolve the issue, restart the computer or device.
Posted 27 days ago. Oct 24, 2017 - 16:40 UTC
Investigating
We are receiving reports of customers experiencing delays in starting sessions and issues logging into GoToMeeting, GoToWebinar and GoToTraining. We are investigating the issue and will update this page as soon as possible.
Posted 27 days ago. Oct 24, 2017 - 16:20 UTC
This incident affected: GoToMeeting, GoToWebinar, and GoToTraining.