Login website unavailable
Resolved
This issue has been fully resolved and GoToMeeting is 100% operational at this time.
Posted Apr 28, 2016 - 15:52 UTC
Monitoring
The issue has been identified and resolved. The website is back again and login should work without any issue.

We apologize for the inconvenience this may have caused top you and you customers
Posted Apr 28, 2016 - 12:56 UTC
Investigating
Currently some customers my not be able to login via the gotomeeting.com website. Start or join a session via the Desktop App is not affected.
We are working on a solution and apologize for the inconvenience this may cause to you and your customers
Posted Apr 28, 2016 - 12:40 UTC
This incident affected: GoToMeeting, GoToWebinar, and GoToTraining.