GoToWebinar registration page fails to load
Resolved
This issue is now resolved. We sincerely apologize for the disruption in service to you and your customers.
Posted Aug 05, 2015 - 16:01 UTC
Investigating
We are investigating an issue whereby the GoToWebinar registration page fails to load for at least some customers. We sincerely apologize for the disruption in service to you and your customers. This is top priority and we are working towards a resolution as quickly as possible.
Posted Aug 05, 2015 - 14:26 UTC
This incident affected: GoToWebinar.