German GotoMeeting Phone Number not reachable
Incident Report for GoToMeeting® External Status
Resolved
All systems are operational and continue to monitor them closely.

We apologize for the inconvenience this may have caused to you and your customers.
Posted 10 months ago. Feb 08, 2017 - 02:29 EST
Investigating
Currently we experience issues with German GotoMeeting Numbers. The Numbers are not reachable.
The affected Numbers:
+496925736 xxx

Alternative Numbers are in place. Please find more information: https://care.citrixonline.com/article/000310856

We apologize for the inconvenience this may cause
Posted 10 months ago. Feb 07, 2017 - 09:25 EST
This incident affected: GoToMeeting, GoToWebinar, GoToTraining, and OpenVoice.