Blank page when clicking on the registration link
Resolved
All links should now work again. We sincerely apologize for the disruption in service to you and your customers.
Posted Sep 10, 2015 - 11:03 UTC
Investigating
Some customers are reporting a blank page when clicking on the registration link. Citrix Engineering are currently investigating the issue. We sincerely apologize for the disruption in service to you and your customers. This is top priority and we are working towards a resolution as quickly as possible.
Posted Sep 10, 2015 - 10:44 UTC
This incident affected: GoToWebinar.