Delay or inability to reach our websites or connect to our services
Resolved
Our testing has confirmed that there are no longer any issues with ISP handling GoToMeeting, GoToWebinar, or GoToTraining traffic. As there have been no further reports from customers experiencing connectivity issues, we consider this incident now closed. We thank you for your understanding and patience.
Posted Jun 23, 2016 - 18:47 UTC
Identified
At this time our services are fully operational, however some customers are experiencing delays or an inability to reach our websites or connect to our services. Unfortunately a number of Internet Service Providers are still experiencing load balancing issues, which have continued since Friday. We are keeping in close contact with the main ISPs and requesting status updates from them so that we can keep you informed. You can check if your ISP is affected here: http://downdetector.com/
Posted Jun 20, 2016 - 18:15 UTC
This incident affected: GoToMeeting, GoToWebinar, and GoToTraining.