UK GoToMeeting website is down (co.uk)
Resolved
The website is working again. We sincerely apologize for the disruption in service to you and your customers.
Posted Apr 20, 2015 - 14:05 UTC
Update
The issue is still under investigation. Please use the US site gotomeeting.com until the issue is fixed. We sincerely apologize for the disruption in service to you and your customers. This is top priority and we are working towards a resolution as quickly as possible
Posted Apr 20, 2015 - 12:26 UTC
Investigating
http://www.gotomeeting.co.uk/, http://www.gotomeeting.co.uk/webinar , http://www.gotomeeting.co.uk/training
are down and not working. Please use the US site gotomeeting.com until the issue is fixed. We sincerely apologize for the disruption in service to you and your customers. This is top priority and we are working towards a resolution as quickly as possible.
Posted Apr 20, 2015 - 10:40 UTC
This incident affected: GoToMeeting, GoToWebinar, and GoToTraining.