Unable to access gotomeet.me
Resolved
At this time, gotomeet.me is 100% operational and all customers are able to join or start meetings using gotomeet.me. We apologize for any inconvenience this may have caused.
Posted Nov 17, 2015 - 22:50 UTC
Investigating
Customers are currently unable to join meetings via the gotomeet.me landing page. We sincerely apologize for any inconvenience this may be causing you or your customers. We are working to restore services as soon as possible.
Posted Nov 17, 2015 - 19:17 UTC
This incident affected: GoToMeeting.