Comcast service issues affecting customers.
Resolved
This incident has been resolved.
Posted about 1 year ago. Nov 06, 2017 - 23:20 UTC
Identified
At this time customers connecting to our services via Comcast/Xfinity are experiencing connectivity issues. Please refer to this page for more http://downdetector.com/status/comcast-xfinity/map/
Posted about 1 year ago. Nov 06, 2017 - 18:51 UTC
This incident affected: GoToMeeting, GoToWebinar, and GoToTraining.