Issue with the admin center
Resolved
At this time service has been fully restored. We apologize for any frustration experienced and thank you for your patience.
Posted Dec 09, 2014 - 18:29 UTC
Investigating
We are currently aware of an issue with the admin center that is affecting customers. At least some customers cannot log on to the Admin Center independently from what web browser is used.
We sincerely apologize for the disruption in service to you and your customers. This is top priority and we are working towards a resolution as quickly as possible.
Posted Dec 09, 2014 - 14:55 UTC