OpenVoice Canadian Toll Numbers - Fast Busy
Incident Report for GoToMeeting® System Status
Resolved
Our engineers have identified and corrected the issue. We are 100% operational at this time.
Thank you for your patience.
Posted 2 months ago. Jul 20, 2017 - 14:52 UTC
Investigating
Customers are reporting difficulty reaching our Canadian Toll numbers for OpenVoice. GoToMeeting and GoToWebinar are not impacted at this time. Our engineers are actively investigating the root cause. We apologize sincerely for those that are affected.

A workaround for Canadian callers would be to utilize any available toll free numbers or else dial internationally to the US numbers.
Posted 2 months ago. Jul 20, 2017 - 14:42 UTC
This incident affected: OpenVoice.