Important updates for Admins after the merger with LogMeIn Inc.
Resolved
This incident has been resolved.
Posted Nov 08, 2017 - 00:24 UTC
Identified
We’re happy to announce that on January 31, 2017, the GoTo business of Citrix (which includes GoToMeeting, GoToWebinar, GoToTraining, GoToMyPC, GoToAssist, OpenVoice, Grasshopper and Event Services) separated from Citrix Systems, Inc. and merged with LogMeIn, Inc. For our customers, the new LogMeIn will offer best-in-class capabilities across a much larger combined portfolio while featuring the scale, resources and world-class talent required to accelerate innovation and address future customer needs.

We are very excited about the possibilities this merger presents for our customers. For the vast majority of customers, no actions will be needed. Our applications will continue to update automatically and take care of any changes required.

If you are an IT Admin, Billing Admin or have an Integration based on one of our APIs, you will need to make some updates. Full details of what you will need to do can be found here: https://support.logmeininc.com/account-update-faqs

Please follow this announcement in our customer community so you are automatically updated with new information as it becomes available: https://community.gotomeeting.com/gotomeeting/topics/important-updates-for-admins-after-the-merger-with-logmein-inc
Posted May 24, 2017 - 23:27 UTC
This incident affected: GoToMeeting, GoToWebinar, and GoToTraining.