GoToMeeting website issues
Resolved
We are 100% operational again at this time. We sincerely apologize for any inconvenience caused by this issue to you and your customers.
Posted Aug 27, 2014 - 11:26 UTC
Identified
We have Identified a potential root cause and are working to restore service.
Posted Aug 27, 2014 - 10:18 UTC
Investigating
Some Customers currently may experience problems with our GoToMeeting Service (accessing and changing the meeting schedules ). We sincerely apologize for the disruption in service to you and your customers. This is top priority and we are working towards a resolution as quickly as possible.
Posted Aug 27, 2014 - 09:53 UTC
This incident affected: GoToMeeting, GoToWebinar, and GoToTraining.