Dropped calls and computer audio not connecting
Resolved
Monitoring is complete and we have confirmed we are currently 100% operational.

Thank you for your patience while this incident was investigated. We apologize, again, for any inconvenience to organizers and their participants.
Posted Jul 22, 2016 - 14:36 UTC
Update
We are continuing to investigate the cause of the current audio issues. Some changes have been made to improve over all stability and quality.
Posted Jul 21, 2016 - 18:44 UTC
Investigating
We are currently investigating reports of OpenVoice, GoToMeeting and GoToWebinar audio issues. A potential workaround is to start a Meet Now, in place of your scheduled meeting. We apologize for any frustration or inconvenience experienced.
Posted Jul 21, 2016 - 15:44 UTC
This incident affected: GoToMeeting, GoToWebinar, and OpenVoice.