Delays or inability to start new GoToMeeting sessions
Resolved
This issue is now resolved, we apologize for any frustration or inconvenience it may have caused.
Posted Aug 21, 2014 - 17:53 UTC
Investigating
We are currently investigating an issue that is affecting some customers. Affected customers may experience delays or be unable to launch new sessions.
Posted Aug 21, 2014 - 17:45 UTC
This incident affected: GoToMeeting.