GoToWebinar Email Latency
Resolved
GoToWebinar emails are now 100% operation. We apologize for any trouble this may have caused you.
Posted Aug 12, 2014 - 19:00 UTC
Investigating
We are currently investigating an issue that is causing latency in sending GoToWebinar email invitations. We are working to identify the cause and resolve this delay. We apologize for any frustration or inconvenience this issue is causing.
Posted Aug 12, 2014 - 17:13 UTC
This incident affected: GoToWebinar.