Blank page when clicking on the registration link
Resolved
Service has been fully restored. We sincerely apologize for the inconvenience to you and your customers.
Posted Sep 10, 2015 - 15:34 UTC
Monitoring
All links should work now again. We sincerely apologize for the disruption in service to you and your customers.
Posted Sep 10, 2015 - 13:02 UTC
Investigating
We get reports again about the earlier issue with the registration link. Some customers are reporting a blank page when clicking on the registration link. Citrix Engineering are currently investigating the issue. We sincerely apologize for the disruption in service to you and your customers. This is top priority and we are working towards a resolution as quickly as possible.
Posted Sep 10, 2015 - 12:45 UTC
This incident affected: GoToWebinar.