GoToMeeting - issue resolved.
Resolved
LogMeIn has confirmed that the identified issue impacting some GoToMeeting customers who may have been experiencing problems with launching a new meeting has been resolved completely and all systems are operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted 23 days ago. Oct 22, 2018 - 10:54 UTC
Monitoring
At this time, we have addressed the identified issue impacting some GoToMeeting customers who may have been experiencing problems with launching a new meeting.

We will continue to monitor the situation and will provide a final update shortly.
Posted 23 days ago. Oct 22, 2018 - 10:45 UTC
Identified
We believe we have identified the issue impacting some GoToMeeting customers who may be experiencing problems with launching a new meeting. Our team is now actively working to resolve the issue, and we will provide another update shortly.
Posted 23 days ago. Oct 22, 2018 - 10:05 UTC
Investigating
LogMeIn is actively investigating reports that some customers using GoToMeeting may be experiencing issues while launching a meeting.

We’re working to restore complete functionality to all users and we will provide another update shortly.
Posted 23 days ago. Oct 22, 2018 - 09:38 UTC
This incident affected: GoToMeeting.