Delay accessing GotoMeeing, GotoWebinar, GotoTraining Webportal (EMEA)
Incident Report for GoToMeeting® External Status
Resolved
This incident has been resolved.
Posted 10 months ago. Feb 07, 2017 - 09:26 EST
Investigating
Some EMEA based users may experience delays using our GotoMeeting,GotoWebinar or GotoTraining Services. Our Network Team is working with affected Internet Service Providers on a solution.
We apologize for the inconvenience this may have.
Posted 11 months ago. Feb 01, 2017 - 11:58 EST