Delays in GoToWebinar invite email
Resolved
This issue has now been resolved, we apologize for any frustration that was caused.
Posted Sep 03, 2014 - 20:32 UTC
Monitoring
We have made changes in an effort to restore service. We are currently monitoring the situation and customer feedback.
Posted Sep 03, 2014 - 19:40 UTC
Investigating
We are currently investigating reports that some GoToWebinar email is being delayed before it is sent. We apologize for any inconvenience this is causing.
Posted Sep 03, 2014 - 18:55 UTC
This incident affected: GoToWebinar.