Gotomeeting, Gotomeet.me login or session start not possible
Incident Report for GoToMeeting® System Status
Resolved
A fix has been deployed and all tests have been successful. The few affected customers ar now able to use all GotoMeeting functionality as before.

We apologize for the inconvenience this may have caused to you and your customers
Posted 4 months ago. Aug 04, 2017 - 09:06 UTC
Identified
We identified a few users who are currently not able to use the GotoMeeting service nor login into their Gotomeeting portal. We are working towards a solution.

We apologize for the inconvenient this may cause
Posted 4 months ago. Aug 04, 2017 - 08:18 UTC
This incident affected: GoToMeeting.