GoToWebinar - registration and reminder email delay
Incident Report for GoToMeeting® External Status
Resolved
GoToWebinar registration emails and notifications are now being sent without delay. We will continue to monitor the service closely.

We apologize for the inconvenience.
Posted about 1 year ago. Sep 19, 2016 - 14:53 EDT
Investigating
We have received reports of delayed webinar registration and reminder emails. We are working to get this resolved as quickly as possible.

We apologize for any inconvenience this is causing you or your customers.
Posted about 1 year ago. Sep 19, 2016 - 10:31 EDT
This incident affected: GoToWebinar.