Intermittent Issues Reaching GoToWebinar Registration Pages
Resolved
This issue has been resolved and service is 100% operational. We sincerely apologize for the disruption in service to you and your customers.
Posted May 14, 2015 - 21:21 UTC
Investigating
We have identified an issue intermittently affecting GoToWebinar registration pages at attendee.gotowebinar.com - the page will give a failed to load error, or will load partially with branding and formatting unavailable. We are actively investigating this issue and working toward a resolution.
Posted May 14, 2015 - 19:22 UTC
This incident affected: GoToWebinar.