GoToMeeting - Problem with joining meetings
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted 9 days ago. Oct 07, 2019 - 22:51 UTC
Monitoring
Our engineers have corrected the issue and we are confirming that all services are functional.

We will continue to monitor the situation and will provide a final update shortly.
Posted 9 days ago. Oct 07, 2019 - 19:46 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 10 days ago. Oct 07, 2019 - 19:18 UTC
Investigating
We are actively investigating reports that some GoToMeeting customers may be experiencing issues with joining their GoToMeeting rooms.

Our engineers are working to resolve the issue and will provide another update shortly.
Posted 10 days ago. Oct 07, 2019 - 18:46 UTC
This incident affected: GoToMeeting.