GoToMeeting, GoToTraining, GoToWebinar, OpenVoice issue is Resolved
Resolved
LogMeIn has confirmed that the identified issue impacting some GoToMeeting, GoToTraining, GoToWebinar & OpenVoice customers who may have been experiencing issues with loading the webpage for the products has been resolved completely and all systems are operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted 24 days ago. Jan 31, 2019 - 16:37 UTC
Monitoring
At this time, we have addressed the identified issue impacting some GoToMeeting, GoToTraining, GoToWebinar & OpenVoice customers who may have been experiencing issues with loading the webpage for the products.

We will continue to monitor the situation and will provide a final update shortly.
Posted 24 days ago. Jan 31, 2019 - 16:21 UTC
Update
This is only affecting the products webpage, not the applications themselves. Users can go to global.gotomeeting.com to go directly to the login page.
Posted 24 days ago. Jan 31, 2019 - 15:28 UTC
Identified
We believe we have identified the issue impacting GoToMeeting, GoToTraining, GoToWebinar & OpenVoice customers who may be experiencing problems with loading the webpage for the products. Our team is now actively working to resolve the issue, and we will provide another update shortly.
Posted 24 days ago. Jan 31, 2019 - 15:18 UTC
Investigating
LogMeIn is actively investigating reports that GoToMeeting, GoToTraining, GoToWebinar & OpenVoice customers may be experiencing issues with loading the webpage for the products.

We’re working to restore complete functionality to all users and we will provide another update shortly.
Posted 24 days ago. Jan 31, 2019 - 15:16 UTC
This incident affected: GoToMeeting, GoToWebinar, GoToTraining, and OpenVoice.