GoToMeeting, GoToWebinar, GoToTraining and OpenVoice - Performance Issue
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.
Posted Aug 30, 2020 - 16:22 UTC
Monitoring
Our third party Internet Service Provider has confirmed restoration of services and the health checks of our products indicate they are now functional as expected.
We will continue to monitor the situation and will keep you posted with updates.
Posted Aug 30, 2020 - 15:41 UTC
Identified
We are actively investigating reports that some GoToMeeting, GoToWebinar, GoToTraining, and OpenVoice customers may be experiencing performance issues with these products.
Our Engineers have isolated this product impact due to a widespread Third Party Internet Service Provider outage across North America. We expect product functionalities to improve but there is a potential for ongoing interruptions as long as the ISPs are experiencing interruption.
Posted Aug 30, 2020 - 13:49 UTC
This incident affected: GoToMeeting, GoToWebinar, GoToTraining, and OpenVoice.