OpenVoice - Toll free not working in some regions
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted 3 months ago. Jul 25, 2019 - 17:47 UTC
Monitoring
Our engineers have corrected the issue and we are confirming that all services are functional.

We will continue to monitor the situation and will provide a final update shortly.
Posted 3 months ago. Jul 25, 2019 - 17:16 UTC
Investigating
We are actively investigating reports that some Open Voice customers may be experiencing issues dialing Toll-Free Number from Oakland County, Michigan area.

Our engineers are working to resolve the issue and will provide another update shortly.
Posted 3 months ago. Jul 25, 2019 - 16:04 UTC
This incident affected: OpenVoice.