GoToWebinar - Customers are unable to run reports on Previous Webinars
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted 10 days ago. Sep 05, 2019 - 22:25 UTC
Investigating
We are actively investigating reports that some GoToWebinar customers may be experiencing issues when running reports on Previous Webinars.

Our engineers are working to resolve the issue and will provide another update shortly.
Posted 10 days ago. Sep 05, 2019 - 20:04 UTC
This incident affected: GoToWebinar.