Maintenance Announcements
Incident Report for GoToMeeting® External Status
Resolved
The Maintenance is completed.

We apologize for the iconvenience this may have caused
Posted 4 months ago. Aug 16, 2017 - 03:32 EDT
Investigating
In order to provide our customers with the highest level of service, we have scheduled maintenance on GotoMeeting. The expected down time is 20-30min. During this time users will not be able to start new sessions on GoToMeeting, GoToTraining & GoToWebinar. In-flight sessions will be unaffected.. We sincerely apologize for the inconvenience caused by this maintenance.
Posted 4 months ago. Aug 16, 2017 - 02:41 EDT
This incident affected: GoToMeeting, GoToWebinar, and GoToTraining.