Inability to purchase plan
Resolved
This issue is now resolved and customers are able to complete transactions. We apologize for any inconvenience this may have caused.
Posted Nov 10, 2015 - 20:02 UTC
Identified
We have identified an issue that is impacting customer's ability to purchase a plan. We are actively working on a resolving this issue and will provide updates as they become available.
Posted Nov 10, 2015 - 18:54 UTC
This incident affected: GoToMeeting and GoToWebinar.