GoToTraining Linux and Chromebook users unable to join
Resolved
GoToTraining is 100% operational. We sincerely apologize for any frustration or inconvenience caused to you and your customers.
Posted Nov 19, 2014 - 19:39 UTC
Identified
We have identified an issue that will prevent customers using the Chrome or Linux Operating Systems from joining GoToTraining sessions. We are working to correct this issue and restore service as soon as possible. We apologize for any inconvenience experienced.
Posted Nov 19, 2014 - 18:29 UTC
This incident affected: GoToTraining.