Unable to Purchase, or Make Account Changes
Resolved
We have identified the cause of the issue, and the affected services were restarted to restore full functionality. This issue should now be resolved, and all account changes should now function as normal. We apologize for any frustration this may have caused.
Posted Feb 27, 2015 - 04:45 UTC
Investigating
We have identified an issue that is preventing GoToMeeting, GoToWebinar, GoToTraining, and OpenVoice customers from making changes to their accounts. This includes creating new trials or plans, changing plans, updating the email address or password, or repurchasing lapsed accounts. This is a top priority and we are actively investigating a resolution at this time.
Posted Feb 27, 2015 - 04:23 UTC
This incident affected: GoToMeeting, GoToWebinar, GoToTraining, and OpenVoice.