US Toll Free Calls Not Completing
Incident Report for GoToMeeting® External Status
Resolved
No additional reports of this issue have been received since the change was made. OpenVoice is now 100% operational.
Posted 10 days ago. Dec 05, 2017 - 09:04 EST
Monitoring
Our network team has made a change to how calls are delivered and calls are now completing successfully. The listed workarounds should no longer be required. We will continue to monitor to ensure there are no further problems.

Thank you for your patience.
Posted 10 days ago. Dec 05, 2017 - 08:57 EST
Investigating
Currently, some customers are experiencing problems reaching our US Toll Free numbers. We recommend those impacted use our US Toll numbers if they're experiencing this problem.

A high priority ticket has been filed to investigate. We sincerely apologize to those affected.
Posted 10 days ago. Dec 05, 2017 - 08:54 EST
This incident affected: OpenVoice.