GoToMeeting Service Unavailable messge
Resolved
At this time service has been fully restored. We apologize for the frustration and inconvenience caused.
Posted Aug 28, 2014 - 16:02 UTC
Investigating
We are investigating an issue that may be affecting some customers currently, affected customers will see an error stating "Service Unavailable" when they try to login to their accounts on www.gotomeeting.com. We apologize for the frustration this is causing and will continue to update you and this issue develops.

Please note: GoToMeetings can be scheduled, started and joined directly via the GoToMeeting software, without needing to access the website.
Posted Aug 28, 2014 - 15:07 UTC
This incident affected: GoToMeeting, GoToWebinar, and GoToTraining.