OpenVoice issue resolved
Resolved
LogMeIn has confirmed that the issue impacting some OpenVoice customers who may have been experiencing problems with scheduling a meeting has been resolved completely and all systems are operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted about 2 months ago. Oct 30, 2018 - 09:22 UTC
Monitoring
At this time, we have addressed the issue impacting some OpenVoice customers who may have been experiencing problems with scheduling a meeting.

We will continue to monitor the situation and will provide a final update shortly.
Posted about 2 months ago. Oct 30, 2018 - 09:06 UTC
Identified
We believe we have identified the issue impacting some OpenVoice customers who may be experiencing problems with scheduling a meeting. Our team is now actively working to resolve the issue, and we will provide another update shortly.
Posted about 2 months ago. Oct 30, 2018 - 08:25 UTC
Update
Our engineers are continuing to investigate the issue. We will keep you updated with the progress
Posted about 2 months ago. Oct 30, 2018 - 06:59 UTC
Investigating
LogMeIn is actively investigating reports that some OpenVoice customers may be experiencing issues with scheduling a meeting.

We’re working to restore complete functionality to all users and we will provide another update shortly.
Posted about 2 months ago. Oct 30, 2018 - 05:36 UTC
This incident affected: OpenVoice.