GoToWebinar - Issue resolved.
Resolved
LogMeIn has confirmed that the identified issue impacting some GoToWebinar customers who may have been experiencing problems with joining a webinar has been resolved completely and all systems are operational at this time.

We will conduct an internal investigation of this issue and make appropriate improvements to our systems to help prevent or minimize future recurrence.
Posted 5 months ago. Jun 28, 2018 - 10:08 UTC
Investigating
LogMeIn is actively investigating reports that some attendees may have been unable to join GoToWebinar.

We’re working to restore complete functionality to all users and we will provide another update shortly.
Posted 5 months ago. Jun 28, 2018 - 10:05 UTC
This incident affected: GoToWebinar.