Some Admins are currently unable to manage users and seats
Resolved
We are 100% operational again.
Posted Jun 18, 2015 - 11:02 UTC
Investigating
Some Admins are currently unable to manage users and seats in the Admin Center. The issue is under investigation. We sincerely apologize for the disruption in service to you and your customers. This is top priority and we are working towards a resolution as quickly as possible.
Posted Jun 18, 2015 - 09:47 UTC
This incident affected: GoToMeeting, GoToWebinar, and GoToTraining.