ISP Carrier Service Disruption
Resolved
We are no longer receiving reports of connectivity issues and affected ISP's appear to be stable.
Posted 16 days ago. Jul 02, 2018 - 15:10 UTC
Update
We continue to see stabilization with ISP providers, but will continue to monitor through the weekend.
Posted 19 days ago. Jun 29, 2018 - 22:39 UTC
Monitoring
We have reports of some ISP's coming back online and will continue to monitor the situation.
Posted 19 days ago. Jun 29, 2018 - 19:13 UTC
Identified
Some customers are currently being impacted by ISP outages across North America. These outages may be impacting customer's ability to use our services. Please contact your ISP if you continue to experience issues. We are currently working to identify and resolve any issues with our local ISP, and will update this page with any new information
Posted 19 days ago. Jun 29, 2018 - 17:53 UTC
This incident affected: GoToMeeting, GoToWebinar, GoToTraining, and OpenVoice.