Customer Support Phone system disturbed
Incident Report for GoToMeeting® External Status
Resolved
The issue has been resolved - Customer Support can be reached over phone again.

We apologize for the inconvenience
Posted 6 months ago. Jun 16, 2017 - 04:49 EDT
Investigating
We currently experience issue with our Customer Support phone system. You may not be able to reach us by phone at this moment. Goto-Products are not affected.
Please visit our Support site for help: https://support.logmein.com/
Posted 6 months ago. Jun 16, 2017 - 03:59 EDT