GoToMeeting - Unable to launch meetings
Resolved
We have confirmed that the issue has been resolved completely and all systems are 100% operational at this time.
Posted Mar 19, 2020 - 16:11 UTC
Identified
We are seeing unprecedented customer traffic accessing GoToMeeting and some users may be experiencing a delay in joining meetings. Customers are requested to re-try starting or joining the meeting. We are working to mitigate any future issues.
Posted Mar 18, 2020 - 16:03 UTC
This incident affected: GoToMeeting.